Error: Access violation at 0x_ (tried to write to 0x_), program terminated.

Post your bug reports and support issues here.
Post Reply
Ric_Walker
Posts: 3
Joined: Wed Nov 25, 2020 5:54 pm

Error: Access violation at 0x_ (tried to write to 0x_), program terminated.

Post by Ric_Walker »

I'm getting this error again. However this time I can't seem to get past it (last time I would get the error 1-6 times before the program would successfully open), and the program will not open. There's a history via email here. Had this fixed with a new v3.2 that Anton sent me on Sept 6, 2020 and have been going just fine until "today" (last sync was on 11/16/2020), I mostly sync on Monday mornings, but missed this week. I'm going to try to document here that others can benefit from what I'm experiencing, along with the needed fix.

Image

My system (same then as now, exception of MS updates):
• Windows 10 Pro, v1909, 64-bit
• Microsoft Office Home and Business 2019 | Microsoft Outlook 2019 MSO (16.0.13328.21334) 32-bit
• Outlook-Android Sync, v3.2 (32-bit) -> "OAS" for future reference here.

What has happened since 11/16/2020:
• Microsoft did an office update last week. It created, once again, a message that pops up saying that some unknown program can't run. This popup reoccurs about 3 seconds after you close it while Outlook is open. Close outlook and it stops popping up. This is fixed each time it happens by going to "Apps & Features", selecting "Modify" for Office and doing an "Online Repair" ("Quick Repair" doesn't fix it).
• I've not had to repair office since last winter/spring, to my memory.

What I've done this time:
• Tried to open OAS many times. Each resulting in the error message.
• I completely closed Outlook. Tried to open OAS, many times, each resulting in the error message and clicking [OK] just closes the message (program already closed).
• I shut everything down, rebooted, Tried to open OAS to same effect. Error message every time.
• Checked the ezoutlooksync site and found that there was a new version - v3.3 that has both 32-bit and 64-bit. Downloaded.
• Installed the new v3.3 and tried to open OAS to same effect. Error message every time.
• Used SCANPST.exe to repair my Outlook.pst file (found 7 errors, repaired). It would seem to me that this would hinder a sync and not the opening of OAS.
• Tried to open OAS many times, again each with the error message.
• Rebooted, tried again to no avail.

Now I'm here putting all this down. I need this to sync as I've set things for next week that I want calendar "alarms" for. Please, for God's sake, come up with a solution. I can't be the only one experiencing this for the last 2 years (searched previous posts).

Ric

=== Update on things attempted ===
• Under File Explorer, I tried "Error checking" on both C (OS) and D (Data) drives. Nothing found.
• Rebooted to "Active@Boot" and used their "Check Local Drives" disk check utility. It did find and fix errors on C.
• Rebooted back to Windows 10 Pro. Tried to open OAS and failed with same message on first try. Succeeded opening on second try. Sync'd, made an edit to one entry on the phone, and Sync'd again.
• Shut down OAS. Opened Outlook and can't open OAS (same error message over and over).
• Made a change to an entry in Calendar and closed Outlook.
• Took 6 tries to get OAS to open (got same error message on first 5). Once opened, successfully sync'd.
• Closed OAS and then tried to open it again. Took 8 tries before I didn't get the error message and it opened. Successfully sync'd again.

In the past I've always been able to open Outlook and then while doing email, open OAS and sync calendar and contacts at the same time. At least for a while looks like I need to open OAS after boot before opening Outlook.

Ric
admin
Site Admin
Posts: 651
Joined: Mon Jan 03, 2005 5:21 pm

Re: Error: Access violation at 0x_ (tried to write to 0x_), program terminated.

Post by admin »

That's an interesting observation you made in the last sentence. Will check on our side what could be causing the error message. Will update this post once I have more info.
admin
Site Admin
Posts: 651
Joined: Mon Jan 03, 2005 5:21 pm

Re: Error: Access violation at 0x_ (tried to write to 0x_), program terminated.

Post by admin »

Ric_Walker, please download the attached file, unpack it, run and click on the Test button. Copy-paste what will be shown in the app here. Thanks!
Attachments
MAPITest.zip
(761.08 KiB) Downloaded 158 times
Ric_Walker
Posts: 3
Joined: Wed Nov 25, 2020 5:54 pm

Re: Error: Access violation at 0x_ (tried to write to 0x_), program terminated.

Post by Ric_Walker »

Ok. Results of the MAPI Test:

Mapi32Dll C:\Program Files (x86)\Microsoft Office\Root\Office16\OLMAPI32.DLL
MAPIInit: 0
MAPIAdminProfiles OK
ProfAdmin.CreateProfile OK
MAPIInit0 OK
MailClient: Microsoft Outlook
Load DLL2: C:\Program Files (x86)\Microsoft Office\Root\Office16\OLMAPI32.DLL
Load OK
MAPIInit2: 0
Mapi32Dll C:\Program Files (x86)\Microsoft Office\Root\Office16\OLMAPI32.DLL
MAPIInit: 0
MAPIAdminProfiles OK
MAPIInit3 OK
admin
Site Admin
Posts: 651
Joined: Mon Jan 03, 2005 5:21 pm

Re: Error: Access violation at 0x_ (tried to write to 0x_), program terminated.

Post by admin »

Thank you, it looks like everything is fine and should be working. Is that before you start Outlook for the first time or after?
Ric_Walker
Posts: 3
Joined: Wed Nov 25, 2020 5:54 pm

Re: Error: Access violation at 0x_ (tried to write to 0x_), program terminated.

Post by Ric_Walker »

I don't remember. Seems that there was one line difference when I ran it, but don't remember the order or what else I had running.
So, here is a sequence of events this morning.

Right after boot with nothing else yet started except normal taskbar items:
• Test:
Mapi32Dll C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
MAPIInit: 0
MAPIAdminProfiles OK
ProfAdmin.CreateProfile OK
MAPIInit0 OK
MailClient: Microsoft Outlook
Load DLL2: C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
Load OK
MAPIInit2: 0
Mapi32Dll C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
MAPIInit: 0
MAPIAdminProfiles OK
MAPIInit3 OK
••


Right after starting OAS (took 1 try to start):
• Test:
Mapi32Dll C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
MAPIInit: 0
MAPIAdminProfiles OK
MAPIInit0 OK
MailClient: Microsoft Outlook
Load DLL2: C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
Load OK
MAPIInit2: 0
Mapi32Dll C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
MAPIInit: 0
MAPIAdminProfiles OK
MAPIInit3 OK
••


Sync'd with phone, closed OAS, opened Outlook 2019:
• Test:
Mapi32Dll C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
MAPIInit: 0
MAPIAdminProfiles OK
MAPIInit0 OK
MailClient: Microsoft Outlook
Load DLL2: C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
Load OK
MAPIInit2: 0
Mapi32Dll C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
MAPIInit: 0
MAPIAdminProfiles OK
MAPIInit3 OK
••


Opened OAS again with Outlook 2019 still running (took 1 try again):
• Test:
Mapi32Dll C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
MAPIInit: 0
MAPIAdminProfiles OK
MAPIInit0 OK
MailClient: Microsoft Outlook
Load DLL2: C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
Load OK
MAPIInit2: 0
Mapi32Dll C:\Program Files (x86)\Microsoft Office\root\VFS\ProgramFilesCommonX86\system\msmapi\1033\msmapi32.dll
MAPIInit: 0
MAPIAdminProfiles OK
MAPIInit3 OK
••


I don't get why today it's opening on first try when last week and the week before it was taking 2 to 8 tries to open each time.
admin
Site Admin
Posts: 651
Joined: Mon Jan 03, 2005 5:21 pm

Re: Error: Access violation at 0x_ (tried to write to 0x_), program terminated.

Post by admin »

Thanks, please run MAPITest after (if) there's the AV error with Outlook-Android Sync upon its start.
Post Reply